Networking
100+ libraries in this category
Package fasthttp is a fast HTTP implementation for Go, up to 10 times faster than net/http
A pure Go implementation of the WebRTC API
Cloudflare Tunnel client (formerly Argo Tunnel)
Simple HTTP and REST client for Go inspired by Ruby rest-client
An implementation of the QUIC protocol in pure Go
`gnet` is a high-performance, lightweight, non-blocking, event-driven networking framework written in pure Go
Go library for working with DNS
Go library for packet processing with libpcap bindings
A library to create a customized HTTP/HTTPS proxy server using Go
A pure go implementation of tun2socks powered by [gVisor](https://gvisor.dev/) TCP/IP stack
Simple Go HTTP client with Black Magic (Less code and More efficiency)
A high-performance non-blocking I/O networking framework, which focused on RPC scenarios, developed by ByteDance
KCP - Fast and Reliable ARQ Protocol
Higher-level API for building SSH servers (wraps crypto/ssh)
HTTPLabs let you inspect HTTP requests and forge responses
BGP implemented in the Go Programming Language
Load testing library and command line tool, advanced echo server and web UI. Allows to specify a set query-per-second load and record latency histograms and other useful stats and graph them. Tcp, Http, gRPC
An enhanced http client with retry and hystrix capabilities
Pure Go 1000k+ connections solution, support tls/http1.x/websocket and basically compatible with net/http, with high-performance and low memory cost, non-blocking, event-driven, easy-to-use
Retryable HTTP client in Go
A Go "clone" of the great and famous Requests library
Simple TUN/TAP library
net/http.Client like HTTP Client with options to select specific client TLS Fingerprints to use for requests
Advanced HTTP client with HTTP/1.1, HTTP/2, HTTP/3 (QUIC), SOCKS5 proxy support and browser-grade TLS fingerprinting
Go library for downloading files or directories from various sources using a URL
High-Performance WebSocket Server & Client With AsyncIO Supporting
gev is a lightweight, fast non-blocking TCP network library based on Reactor mode
Sling is a Go HTTP client library for creating and sending API requests
HTTP requests for Gophers. Uses context.Context and doesn't hide the underlying net/http.Client, making it compatible with standard Go APIs. Also includes testing tools
Package sftp implements the SSH File Transfer Protocol as described in <https://filezilla-project.org/specs/draft-ietf-secsh-filexfer-02.txt>
Go package for managing file downloads
Framework for rapid development of performant network functions for cloud and bare-metal (former YANFF)
Package ftp implements a FTP client as described in [RFC 959](https://tools.ietf.org/html/rfc959)
Simple mDNS (Multicast DNS) client/server library in Golang
Full-featured plugin-driven HTTP client library
A high-performance, recursive DNS resolver server with DNSSEC support, focused on preserving privacy
Gmqtt is a flexible, high-performance MQTT broker library that fully implements the MQTT protocol V3.1.1
Go library for building network and server automation over SSH protocol
Fast IP to CIDR lookup for Go
High performance async-io networking for Golang in proactor mode
A light-weight TCP framework written in Go (Golang), built with message router. EasyTCP helps you build a TCP server easily fast and less painful
Go implementation of the STUN client (RFC 3489 and RFC 5389)
Powerful websocket framework, build your IM server more easily
Pure Go library for cross-platform local peer discovery using UDP multicast
Go HTTP client calls with retries, backoff, and concurrency
Go package for quickly writing tcp applications
Go implementation of RFC 5389 STUN protocol
Go wrapper for libpcap
Fully featured FTP server library
Go WinRM client to remotely execute commands on Windows machines
An easy-to-use HTTP client 100% in Go to spoof TLS/JA3 and HTTP2 fingerprint
Get easily stdlib HTTP client, which does not share any state with other clients
Package raw enables reading and writing data at the device driver level for a network interface.
Package arp implements the ARP protocol, as described in RFC 826
Passive DNS Capture/Monitoring Framework
HTTP client for golang. If you have experience about axios or requests, you will love it. No 3rd dependency
Package ethernet implements marshaling and unmarshalling of IEEE 802.3 Ethernet II frames and IEEE 802.1Q VLAN tags
A secure, efficient TCP/UDP tunneling solution that delivers fast, reliable access across network restrictions using pre-established TCP/QUIC/WebSocket or HTTP/2 connections
A collection of tools for Network Management that use the gNMI and gNOI protocols
Adaptive hedged requests for Go. Cuts p99 latency with zero configuration, based on Google's "The Tail at Scale" paper
Streaming protocolbuffer data over TCP made easy
PostgreSQL server wire protocol. Build your own server and start serving connections.
Jazigo is a tool written in Go for retrieving configuration for multiple network devices
Go uTP micro transport protocol implementation
Package bart provides a Balanced-Routing-Table (BART) for very fast IP to CIDR lookups and more
tcpack is an application protocol based on TCP to Pack and Unpack bytes stream in go program
TCP Server Framework with simultaneous full duplex communication, graceful shutdown, and custom protocol
CoAP Client/Server implementation (RFC 7252)
It's a Super Simples Load Balancer, just a little project to achieve some kind of performance
Library for working with IP addresses (net.IP, net.IPNet), inspired by python [ipaddress](https://docs.python.org/3/library/ipaddress.html) and ruby [ipaddr](https://ruby-doc.org/stdlib-2.5.1/libdoc/ipaddr/rdoc/IPAddr.html)
Hit your API targets with rapid-fire precision using Go's fastest and simple HTTP Client
gldap provides an ldap server implementation and you provide handlers for its ldap operations
Simple I/O event notification library written in Golang
A dead-simple, non-allocating, low level implementation of MQTT well suited for embedded systems
PowerDNS API bindings for Golang
A Powerful, Lightweight, Easy Http Client, inspired by Web Fetch API
Go http.RoundTripper that emits open telemetry metrics for HTTP requests
Make http calls simply and easily
Cross-platform Go package for sending and receiving ethernet frames
A fully featured scriptable and daemon configurable proxy and pivoting toolkit with SOCKS5, HTTP, raw ports and reverse proxy protocols
Package dhcp6 implements a DHCPv6 server, as described in RFC 3315
Send packets over TCP and UDP. It can buffer messages and hot-swap connections if needed.
A simple and intuitive CLI to manage IPTables forwards in your Linux server
Simple TCP proxy which adds CORS support to API's which don't support it
Enriches the default go HTTP client with retry functionality
Network link speed simulation for Reader/Writer interfaces
A nicer interface for golang stdlib HTTP client
A Go HTTP client library inspired by Axios, providing a simple and intuitive API for making HTTP requests
HTTP proxy handler and dialer
Library for making HTTP requests through a pool of proxies offering fault tolerance, load balancing, automatic retries, cookie management, and more, via http.Get/Post replacement or http.Client RoundTripper drop-in
Package publicip returns your public facing IPv4 address (internet egress)
Experimental FTP server framework
A library for Multiplexing HTTP requests based on multiple Source IPs
`gnet` is a high-performance networking framework,especially for game servers
Declarative golang HTTP client
Lightweight, open-source secure tunneling tool to expose local servers to the internet
Package goshark use tshark to decode IP packet and create data struct to analyse packet
It's a very simple but quick backend for proxy servers. Can be useful for fast redirection to predefined domain with zero memory allocation and fast response
Go client and server implementation of HTML server-sent events
Terminal UI for real-time network traffic capture, analysis, and attack detection with JSON output mode